
 

DSP First 
Lab 01: Introduction to LabVIEW 

 
Pre-Lab and Warm-Up: You should read at least the Pre-Lab and Warm-up sections of this lab 
assignment and go over all exercises in the Pre-Lab section before coming to class. 

Verification: The Instructor Verification should be signed off during class time. One of the 
laboratory instructors must verify the appropriate steps by signing on the Instructor 
Verification line. When you have completed a step that requires verification, simply 
demonstrate the step to the instructor. 

Lab Report: It is only necessary to turn in a report on Section 3 with graphs and explanations. 
You are asked to label the axes of your plots and include a title for every plot. In order to keep 
track of plots, include your plot inlined within your report. If you are unsure about what is 
expected, ask. 

1 Pre-Lab 
In this first week, the Pre-Lab will be short and very easy.  Make sure that you read through the 
information in Sections 1-4 below and do everything in Section 1 prior to coming to lab.  Bring 
some headphones so you can listen to some signals. 

1.1 Overview 
LabVIEW will be used extensively in all the labs.  The primary goal of this lab is to familiarize 
your with using LabVIEW.  Here are three specific goals for this lab:  

• Learn basic LabVIEW commands and syntax, including the help system.  
• Learn to write and edit your own VIs (virtual instruments) in LabVIEW, and run them. 
• Learn a little about advanced programming techniques for LabVIEW1.  

1.2 Install LabVIEW 
Here’s how to get LabVIEW installed.  Warning, allow at least 30 minutes to install LabVIEW. 

• Go to \\tibia\public\Course Software\National Instruments\LabVIEW 8.0 
• Run setup.exe.  

• When it asks for a license number, use the one given on Angel. This number is for this 
class only. Please don't give it to others. Doing so will violate our license agreement and 
prevent Rose-Hulman from getting favorable licenses from NI in the future. 

• Select the default answers until you get to Features.  Select the X next to the Driver CD 
as shown below. 

                                                 
1 Read Section I (pages 1-19) of the Introduction to LabVIEW – Six Hour Course (on Angel) for more details.    
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• Continue selecting the defaults until it is all installed. 
• Point your web browser to www.rose-hulman.edu/DSPFirst. 
• Login with the username and password given in class. 
• Click on Getting Started.  (Near the top of the left column.) 
• Scroll to the bottom and follow the instructions for installing the DSP First toolkit. 

1.3 Getting Started - Open and Run a Virtual Instrument 
In this part of the pre-lab you will examine the DSP First Demo VI and run it. Change the 
frequencies and types of the input signals and notice how the display on the graph changes. Here 
is how to do it: 
 
a) Select Start»All Programs»National Instruments»LabVIEW 8.0»LabVIEW to 

launch LabVIEW. The LabVIEW dialog box appears. 
b) Select Help»Find Examples. The dialog box that appears lists and links to all available 

LabVIEW example VIs. 
c) On the Search Tab, enter dsp. Double-click on DSPFirst.  Choose DSP First Demo.vi.  

This will open the DSP First Demo VI Front Panel. 
 
Note: This is how you find all the DSP First demos. 
Front Panel 

a) Check the box next to Play Sound. 

b) Click the Run button ( ) on the toolbar, shown at left, to run this VI once. You 
should hear a short tone.  This VI determines the result of filtering a generated signal. 
This example also displays the magnitude spectrum for the generated signal. The 
resulting signals are displayed in the graphs on the front panel, as shown in the 
following figure.  Try clicking the Time Domain, Spectrum, and Spectrogram tabs 
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to see the various views of the signal. 

 
c) Try changing the signal type and frequency.  You will have to click the Run button 

after each change to see/hear the result. 
 
Block Diagram 
 
a) Select Window»Show Block Diagram or press the <Ctrl-E> keys to display the block 

diagram for the Signal Generation and Processing VI. 
 
(MacOS) Press the <Command-E> keys. (Sun) Press the <Meta-E> keys. 
(Linux) Press the <Alt-E> keys. 
 
This block diagram contains several of the basic block diagram elements, including 
subVIs, functions, and structures, which you will learn about later in this course. 
 

b) Select Window»Show Front Panel or press the <Ctrl-E> keys to return to the Front 
Panel. 
 

c) Close the VI and do not save changes. 
 
2 Warmup: Building VIs – Display Complex Numbers in Polar and 

Rectangular 
The previous exercise gave you experience with running a VI.  The real fun starts when you 
build your own VIs.  The next exercise will walk you through building a VI and modifying it to 
do interesting things.  Complete the following steps to create a VI that takes a complex number 
in polar form and displays it in both polar and rectangular form. 
 
In wiring illustrations, the arrow at the end of this mouse icon shows where to click and the 
number on the arrow indicates how many times to click. 
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Front Panel 
1. Select File»New VI to open a new front panel. 
2. Create a numeric digital control. You will use this control to enter the value for the 

sinusoid magnitude. 
a. Right-click an open area on the front panel to display the Controls palette. 

Select the Numeric Control on the Controls»Modern»Numeric palette. 
b. Move the control to the front panel and click to place the control. 
c. Type Magnitude inside the label and click outside the label. If you do not 

type the name immediately, LabVIEW uses a default label. You can edit a 
label at any time by double clicking on it. 

3. Create a second number control. 
a. Hold the Ctrl key down and click and drag the first control. You now have a 

second control. 
b. Label the second control Phase. 

4. Create a numeric digital indicator. You will use this indicator to display the complex 
value. 

a. Select the Numeric Indicator on the Controls» Modern»Numeric 
palette. 

b. Move the indicator to the front panel and click to place the indicator. 
c. Type Rectangular inside the label and click outside the label. 
d. Make this indicator complex by right-clicking on the control and selecting 

Representation.  Click on the CDB block which is in the middle of the 
bottom row. 

 
LabVIEW creates corresponding control and indicator terminals on the block 
diagram. The terminals represent the data type of the control or indicator. For 
example, a DBL terminal represents a double-precision, floating-point numeric 
control or indicator. 

Block Diagram 
5. Display the block diagram by clicking it or by selecting Window»Show Block 

Diagram. 
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Note:  Block Diagram terminals can be viewed as icons or as terminals.  To change the 
way LabVIEW displays these objects right click on a terminal and select View As Icon.   
 

 
You can make this happen automatically by selecting Tools»Options… then click on 
Block Diagram on the left and unselect “Place front panel terminals as icons”. 

 
6. You can display the complex blocks by right-clicking an open area on the block diagram.  

Select the Polar to Complex function on the Programming»Numeric»Complex 
palette and place them on the block diagram. 
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These are the blocks for manipulating complex numbers.  You should be able to guess what 
they do.  If not, display the Context Help window (Help»Show Context Help or <Ctrl-H>) 
and point to each block. 

7. Use the Wiring tool to wire the icons as shown above. 
• To wire from one terminal to another, hover your cursor near the first 

terminal.  It should turn to a spool of wire.  When it does, click the first 
terminal, move the tool to the second terminal, and click the second terminal, 
as shown in the following illustration. You can start wiring at either terminal. 

 
• You can bend a wire by clicking to tack the wire down and moving the cursor 

in a perpendicular direction. Press the spacebar to toggle the wire direction. 
• When you move the Wiring tool over a terminal, the terminal area blinks, 

indicating that clicking will connect the wire to that terminal and a tip strip 
appears, listing the name of the terminal. 

• To cancel a wire you started, press the <Esc> key, right-click, or click the 
source terminal. 

8. Display the front panel by clicking it or by selecting Window»Show Panel (or 
<Ctrl-E>. 

9. Save the VI because you will use this VI later in the course. 
a. Select File»Save. 
b. Navigate to your class directory. 

Note Save all the VIs you edit in this course in your class directory. 
c. Type Polar to Rect in the dialog box. 
d. Click the Save button. 

10. Enter a number in the digital control and run the VI.  The result is too big for the box, 
so stretch the Rectangular box so you can see both the real and imaginary parts. 

a. Double-click the digital control and type a new number. 
b. Click the Run button to run the VI. 
c. Try several different numbers and run the VI again. 
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11. It would be nice to enter the phase in fractions of π.  Modify your block diagram to 
look like:  

 

Hint:  You will find the π block in the palette that looks like . 
12. Test your VI.  Here’s what mine looks like: 

 
13. Select File»Close to close the VI. 

2.1 Arrays of Complex Numbers 
Throughout this class we will be doing a lot with complex numbers, so let’s see how LabVIEW 
handles arrays of them.   

1. Select File»New VI to open a new front panel. 
2. Go to the front panel and create an array control by right-clicking on the background.  

You will see 

  
Select Array, Matrix & Cluster.  You will see the second palette above, select Array 
and place it on the front panel.  Change the name to z.  Note:  In LabVIEW an array is a 
one dimensional list of elements, while a matrix is a two dimensional list. 
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3. Now you need to say what the array will hold.  Do this by selecting a Numeric Control 
(like you did before) and dragging it into the array. 

    
Release the control and it will look like the middle picture above. 

4. Change the data type to Complex Double (CDB) by right-clicking on the control and 
selecting Representation.  Select CDB from the bottom middle.  You just made this 
control handle complex double values. 

5. Click on the bottom of the control and drag it down a bit.  You will now see something 
like the right-most picture above.  This lets you see and input several values at once. 

6. Switch to the block diagram.  <Ctrl-E> is a fast way to do this. 
7. Your goal is to display the real, imaginary, absolute value, and phase of z using these 

Complex blocks.  I’ll start you with the first one and you should be able to figure out the 
rest.  Place the Complex to Polar block (middle one) on your block diagram and wire as 
shown. 

 
8. Right-click on r terminal of the Complex to Polar block and select Create»Indicator.  

This is a quick way to making a new indicator. 
9. The indicator is labeled r by default.  You may wish to change it to magnitude. 
10. Repeat the process for the phase output as shown below. 
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11. Switch to the front panel and rearrange like: 

 

I find that clicking in 
between the textboxes is a 
good place to “grab” the 
entire control for 
repositioning. 

12. Enter a complex number in z (try 3+j4, which has an easy magnitude)2 and click run.  
Does the correct answer appear?  Add other values to z and try again. 

13. Place the Complex to Re/Im block on the block diagram and attach indicators.  Click 
run and verify that they are working.   

14. Go to the block diagram view and add another complex variable input by holding the Ctrl 
key down and clicking and dragging the z block.  Label this new block w. 

15. Get an add block3 and add z to w.  Attach an indicator.  Verify that it works. Note the 
default label for the add result is ‘x+y’.  You may wish to change it to ‘z+w’. 

  
16. You can combine the arrays z and w into one array.   

                                                 
2 You’ll have to type 3+4i. 
3 Reminder:  right-click on the block diagram to get a palette of blocks.  Click on Numeric and select the Add 
block.  If you aren’t sure where a block is, right-click on the background and then click on Search.  Type the name 
of the block for which you are looking. 
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a. Do this by going to Programming»Array and selecting Build Array. 

 
b. Click on the bottom of the Build Array icon and stretch it until it has two inputs. 
c. Right-click on Build Array and select Concatenate Inputs. 
d. Attach z and w to the inputs. 
e. Create an indicator for the output.  Hint:  Right-click, create. 
f. Run the VI.  Does it work as expected? 
g. This also works for combining scalars into an array. 

17. Save this as Complex Arrays. 
You seen that it is rather easy to build up entire arrays of complex numbers and manipulate them.  
Next you’ll see how to build some signals. 

2.2 Generating Signals 
In this section we’ll see that it’s easy to generate waveforms in LabVIEW.  A waveform is a 
datatype that contains an array of sample values and information about the sampling rate. 

1. Start with a new VI by clicking File:New VI. 
2. Select the block diagram <Ctrl-E>. 
3. Right-click and then click the pushpin in the upper left.  Click on DSP First. You will 

see: 

 
These are the VIs for this class.   

4. Select the DSP First Function Generator (upper left) and place it on the block diagram. 
5. Go to the Front Panel <Ctrl-E>, right-click, choose DSPFirst, then select and place the 

TripleDisplay.   
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This will place a VI on the block diagram.  If the TripleDisplay block has the connector 
on the right side rather than the left side, right-click on it and select Change to Indicator. 

6. Attach the two as shown. 

  
7. Click the run button. 
8. Use the context help4 to learn what the Amplitude, Frequency, Phase, and Sampling Info 

inputs on the DSP First Function Generator default to.  What are the units on the 
Phase? 

9. Attach controls to Amplitude, Frequency, and Phase inputs.  Hint: right-click on the input 
and select Create. 

10. Try different values. 

The DSP First Function Generator generates cosines by default.  You can generate other 
waveforms with it by attaching a control to the signal type connector.  There are many other 
sinusoidal generators in LabVIEW, however they generate sines.  Since Electrical Engineers use 
cosines, stick with our generator. 

2.3 LabVIEW Sound 
The exercises in the section involve sound signals, so you should bring headphones to the lab for 
listening. 

1. Generate a tone (i.e. a sinusoid) in LabVIEW and listen to it.  The previous section 
showed how to generate a sinusoid.  For this part, the frequency of your sinusoid tone 
should be 2000 Hz and its duration should be 1 second.  Use a sampling rate equal to 
11025 samples/sec.  To set the sampling rate and duration, right-click on the sampling 
info terminal on the DSP First Function Generator (bottom left) and select 
Create»Constant.  The top number in the box is the sampling rate and the bottom is the 
number of samples.  Change these to match above. 

                                                 
4 If the small context help window isn’t appearing, type <Ctrl-H> to make it appear. 
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2. Listen to the tone by clicking the Play Sound check box on the TripleDisplay.  Click 
run.  Does the tone sound correct?   

3. The Time Domain display is not very informative at this scale.  See if you can zoom in to 
see something more sinusoidal.  Click the magnifying glass at the bottom of the graph for 
zoom options. 

4. Try different amplitudes and frequencies.  To make this easier, change the input constants 
to controls.  Hint:  right-click the constant and select Create»Control.  Delete the 
constant and attach the control.  Can the frequency be too high or too low? 

Instructor Verification (separate page) 

3 Lab Exercise:  Manipulating Sinusoids with LabVIEW 
Now you're on your own. Include a short summary of this Section with plots in your Lab 
report.  Build a LabVIEW VI to do steps (a) through (d) below. Include a printout of both the 
front panel and the block diagram with your report. 

(a) Set the sampling info so that the Function Generator will produce approximately 
two cycles of the 4000 Hz sinusoids defined in the next part, part (b). Set the 
sampling rate so that you have at least 25 samples per period of the sinusoidal wave. 

(b) Generate two 4000 Hz sinusoids with arbitrary amplitude and time-shift. 
)))(4000(2cos()(

111 mttAtx −= π  )))(4000(2cos()( 222 mttAtx −= π  
Select the value of the amplitudes and time-shifts as follows:  Set A1 equal to your 
age and set A2 = 1.2A1.  For the time-shifts, set TMtm )/2.37(

1
=  and  

TD  where D and M are the day and month of your birthday and T is 
the period.  Make a plot of both signals over the range of Tt 2
tm )/3.41(

2
−=

0 ≤≤ .  For your final 
printed output in part (d) below, place three TripleDisplays one above the other on 
the front panel. 

(c) Create a third sinusoid as the sum: )()()( 213 txtxtx += .  In LabVIEW this amounts to 
summing the vectors that hold the values of each sinusoid.  Make a plot of x3 over the 
same range of time as used in the plots of part (b). 

(d) Before printing the three plots, put a title on each subplot, and include your name in 
one of the titles.  Then right-click on each plot and select Data Operations»Export 
Simplified Image…5.  Put the plot on your clipboard and then paste into your word 
processor. 

3.1 Theoretical Calculations 
Remember that the phase of a sinusoid can be calculated after measuring the time location of a 
positive peak,6 if we know the frequency. 

(a) Make measurements of the “time-location of a positive peak” and the amplitude from 
the plots of x1 and x2, and write those values for Ai and 

imt  directly on the plots.  
Then calculate (by hand) the phases of the two signals, x1(t) and x2(t),  by converting 
each time-shift 

imt  to phase. Write the   calculated phases φi directly on the plots. 
Note: when doing computations, express phase angles in radians, not degrees! 

                                                 
5 If Export Simplified Image doesn’t appear, press Alt-PrintScrn and paste into your word processor. 
6 Usually we say time-delay or time-shift instead of the “time location of a positive peak.” 
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(b) Measure the amplitude A3 and time-shift 
3mt directly from the plot and then calculate 

the phase φ3 by hand.  Write these values directly on the plot to show how the 
amplitude and time-shift were measured, and how the phase was calculated. 

(c) Now use the phasor addition theorem. Carry out a phasor addition of complex 
amplitudes for x1(t) and x2(t) to determine the complex amplitude for x3(t).  Use the 
complex amplitude for x3(t) to verify that your previous calculations of A3 and φ3 
were correct. 

 
4 LabVIEW things to remember for future labs: 

• Where to find DSP First demos 
• How to turn on and use Context Help 
• Using right-click to find palettes 
• How to search for VIs (blocks) 
• Using right-click to attach constants, controls, and indicators 
• Where to find the complex operators 
• How to create array controls 
• How to declare the ‘type’ of an array 
• How to change the data representation of a numeric input 
• How to generate a cosine waveform 
• How to change the sampling rate and number of samples generated 
• How to use a TripleDisplay. 
• How to copy a plot to be pasted into a word processor. 
• …  What else? 
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DSP First


Lab 01: Introduction to LabVIEW


Pre-Lab and Warm-Up: You should read at least the Pre-Lab and Warm-up sections of this lab assignment and go over all exercises in the Pre-Lab section before coming to class.


Verification: The Instructor Verification should be signed off during class time. One of the laboratory instructors must verify the appropriate steps by signing on the Instructor Verification line. When you have completed a step that requires verification, simply demonstrate the step to the instructor.

Lab Report: It is only necessary to turn in a report on Section 3 with graphs and explanations. You are asked to label the axes of your plots and include a title for every plot. In order to keep track of plots, include your plot inlined within your report. If you are unsure about what is expected, ask.

1 Pre-Lab

In this first week, the Pre-Lab will be short and very easy.  Make sure that you read through the information in Sections 1-4 below and do everything in Section 1 prior to coming to lab.  Bring some headphones so you can listen to some signals.

1.1 Overview


LabVIEW will be used extensively in all the labs.  The primary goal of this lab is to familiarize your with using LabVIEW.  Here are three specific goals for this lab: 

· Learn basic LabVIEW commands and syntax, including the help system. 

· Learn to write and edit your own VIs (virtual instruments) in LabVIEW, and run them.

· Learn a little about advanced programming techniques for LabVIEW
. 

1.2 Install LabVIEW


Here’s how to get LabVIEW installed.  Warning, allow at least 30 minutes to install LabVIEW.


· Go to \\tibia\public\Course Software\National Instruments\LabVIEW 8.0

· Run setup.exe. 


· When it asks for a license number, use the one given on Angel. This number is for this class only. Please don't give it to others. Doing so will violate our license agreement and prevent Rose-Hulman from getting favorable licenses from NI in the future.

· Select the default answers until you get to Features.  Select the X next to the Driver CD as shown below.
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· Continue selecting the defaults until it is all installed.


· Point your web browser to www.rose-hulman.edu/DSPFirst.

· Login with the username and password given in class.

· Click on Getting Started.  (Near the top of the left column.)


· Scroll to the bottom and follow the instructions for installing the DSP First toolkit.

1.3 Getting Started - Open and Run a Virtual Instrument


In this part of the pre-lab you will examine the DSP First Demo VI and run it. Change the frequencies and types of the input signals and notice how the display on the graph changes. Here is how to do it:

a) Select Start»All Programs»National Instruments»LabVIEW 8.0»LabVIEW to launch LabVIEW. The LabVIEW dialog box appears.

b) Select Help»Find Examples. The dialog box that appears lists and links to all available LabVIEW example VIs.

c) On the Search Tab, enter dsp. Double-click on DSPFirst.  Choose DSP First Demo.vi.  This will open the DSP First Demo VI Front Panel.


Note:
This is how you find all the DSP First demos.

Front Panel


a) Check the box next to Play Sound.


b) Click the Run button ([image: image2.png]



) on the toolbar, shown at left, to run this VI once. You should hear a short tone.  This VI determines the result of filtering a generated signal. This example also displays the magnitude spectrum for the generated signal. The resulting signals are displayed in the graphs on the front panel, as shown in the following figure.  Try clicking the Time Domain, Spectrum, and Spectrogram tabs to see the various views of the signal.
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c) Try changing the signal type and frequency.  You will have to click the Run button after each change to see/hear the result.

Block Diagram


a) Select Window»Show Block Diagram or press the <Ctrl-E> keys to display the block diagram for the Signal Generation and Processing VI.


(MacOS) Press the <Command-E> keys. (Sun) Press the <Meta-E> keys.


(Linux) Press the <Alt-E> keys.


This block diagram contains several of the basic block diagram elements, including subVIs, functions, and structures, which you will learn about later in this course.


b)
Select Window»Show Front Panel or press the <Ctrl-E> keys to return to the Front Panel.


c)
Close the VI and do not save changes.


2 Warmup: Building VIs – Display Complex Numbers in Polar and Rectangular

The previous exercise gave you experience with running a VI.  The real fun starts when you build your own VIs.  The next exercise will walk you through building a VI and modifying it to do interesting things.  Complete the following steps to create a VI that takes a complex number in polar form and displays it in both polar and rectangular form.
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In wiring illustrations, the arrow at the end of this mouse icon shows where to click and the number on the arrow indicates how many times to click.


Front Panel


1. Select File»New VI to open a new front panel.


2. Create a numeric digital control. You will use this control to enter the value for the sinusoid magnitude.


a. Right-click an open area on the front panel to display the Controls palette. Select the Numeric Control on the Controls»Modern»Numeric palette.


b. Move the control to the front panel and click to place the control.


c. Type Magnitude inside the label and click outside the label. If you do not type the name immediately, LabVIEW uses a default label. You can edit a label at any time by double clicking on it.


3. Create a second number control.


a. Hold the Ctrl key down and click and drag the first control. You now have a second control.


b. Label the second control Phase.


4. Create a numeric digital indicator. You will use this indicator to display the complex value.


a. Select the Numeric Indicator on the Controls» Modern»Numeric palette.


b. Move the indicator to the front panel and click to place the indicator.


c. Type Rectangular inside the label and click outside the label.


d. Make this indicator complex by right-clicking on the control and selecting Representation.  Click on the CDB block which is in the middle of the bottom row.


[image: image4.png]51 untitled 1 Front Panel *

Ele Edt Operate Toos Erowse Window Help
D= 13pt Application Font |~
Magnituds Rectangular
o 0401
Phase
o







LabVIEW creates corresponding control and indicator terminals on the block diagram. The terminals represent the data type of the control or indicator. For example, a DBL terminal represents a double-precision, floating-point numeric control or indicator.


Block Diagram


5. Display the block diagram by clicking it or by selecting Window»Show Block Diagram.
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Note:  Block Diagram terminals can be viewed as icons or as terminals.  To change the way LabVIEW displays these objects right click on a terminal and select View As Icon.  
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You can make this happen automatically by selecting Tools»Options… then click on Block Diagram on the left and unselect “Place front panel terminals as icons”.


[image: image7.png]Cotegory

New and Changed for LabVIEW 8.x

Paths
Performance and Disk

ControlsjFunctions Palettes
Saurce Cortrol

Debugging

Colors

Fonts

Printing

Revision Hitary

Menu shartcuts
Enviranment

Security

Shared Variable Engine.

VI Server: Canfiguration

VI Server: Machine Access
VI Server: User Access

VI Server: Exported VIs
ieh Server: Configuration
ieh Server: Visble Vs
ieh Server: Browser Access

[ Show dots at wire junctions
[V Shows tip strips over terminals

[ Use control caption for subvI tip strips.
T Show subVT names when dropped
¥ Deletecopy panel terminals from disgrem
[ Configure Express ¥ls immediately
[ Enable auto wiring

Minimum distance

—

Maxinum distance

o dns

[ Show wiring quides
i o

[ Enable automatic error handing dislogs

[ Enable automatic wire routing

[V Auto-insert Feedback Node in cycles

T~ Place sub¥ls as expandable.

[ Place structures with Auto Grow enabled
I Show red s on broken wires

[V Labels snap to presst positions on terminals
T Labels locked by default

Defaultlabel position

[pefaut

ok

Cancel

Help







6. You can display the complex blocks by right-clicking an open area on the block diagram.  Select the Polar to Complex function on the Programming»Numeric»Complex palette and place them on the block diagram.
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These are the blocks for manipulating complex numbers.  You should be able to guess what they do.  If not, display the Context Help window (Help»Show Context Help or <Ctrl-H>) and point to each block.

7. Use the Wiring tool to wire the icons as shown above.


· To wire from one terminal to another, hover your cursor near the first terminal.  It should turn to a spool of wire.  When it does, click the first terminal, move the tool to the second terminal, and click the second terminal, as shown in the following illustration. You can start wiring at either terminal.
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· You can bend a wire by clicking to tack the wire down and moving the cursor in a perpendicular direction. Press the spacebar to toggle the wire direction.


· To identify terminals on the nodes, right-click the Multiply and Add functions and select Visible Items»Terminals from the shortcut menu to display the connector pane. Return to the icons after wiring by right-clicking the functions and selecting Visible Items»Terminals from the shortcut menu to remove the checkmark.

· When you move the Wiring tool over a terminal, the terminal area blinks, indicating that clicking will connect the wire to that terminal and a tip strip appears, listing the name of the terminal.


· To cancel a wire you started, press the <Esc> key, right-click, or click the source terminal.


8. Display the front panel by clicking it or by selecting Window»Show Panel (or <Ctrl‑E>.


9. Save the VI because you will use this VI later in the course.


a. Select File»Save.


b. Navigate to your class directory.

Note Save all the VIs you edit in this course in your class directory.

c. Type Polar to Rect in the dialog box.


d. Click the Save button.


10. Enter a number in the digital control and run the VI.  The result is too big for the box, so stretch the Rectangular box so you can see both the real and imaginary parts.

a. Double-click the digital control and type a new number.


b. Click the Run button to run the VI.


c. Try several different numbers and run the VI again.


11. It would be nice to enter the phase in fractions of (.  Modify your block diagram to look like: 
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Hint:  You will find the ( block in the palette that looks like [image: image14.png]



.


12. Test your VI.  Here’s what mine looks like:
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13. Select File»Close to close the VI.


2.1 Arrays of Complex Numbers

Throughout this class we will be doing a lot with complex numbers, so let’s see how LabVIEW handles arrays of them.  


1. Select File»New VI to open a new front panel.


2. Go to the front panel and create an array control by right-clicking on the background.  You will see
[image: image16.png]Q search | 2 view

th; 4o

Modern

ENRNE

I
I
I
I
I
I
[
3

System
Classic

Express

NET & ActiveX.
Addons

User Controls
Select a Control
D5P First






[image: image17.png]Qe [
|+ Modern
L Array, Matrix & Cluster

=l

]

| > system
I
| > Express
| > NET & Activext
| > Addons
| > User Controls
| Select s Control,
> DspFirst






Select Array, Matrix & Cluster.  You will see the second palette above, select Array and place it on the front panel.  Change the name to z.  Note:  In LabVIEW an array is a one dimensional list of elements, while a matrix is a two dimensional list.

3. Now you need to say what the array will hold.  Do this by selecting a Numeric Control (like you did before) and dragging it into the array.
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Release the control and it will look like the middle picture above.

4. Change the data type to Complex Double (CDB) by right-clicking on the control and selecting Representation.  Select CDB from the bottom middle.  You just made this control handle complex double values.

5. Click on the bottom of the control and drag it down a bit.  You will now see something like the right-most picture above.  This lets you see and input several values at once.

6. Switch to the block diagram.  <Ctrl-E> is a fast way to do this.

7. Your goal is to display the real, imaginary, absolute value, and phase of z using these Complex blocks.  I’ll start you with the first one and you should be able to figure out the rest.  Place the Complex to Polar block (middle one) on your block diagram and wire as shown.
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8. Right-click on r terminal of the Complex to Polar block and select Create»Indicator.  This is a quick way to making a new indicator.

9. The indicator is labeled r by default.  You may wish to change it to magnitude.

10. Repeat the process for the phase output as shown below.
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11. Switch to the front panel and rearrange like:
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12. Enter a complex number in z (try 3+j4, which has an easy magnitude)
 and click run.  Does the correct answer appear?  Add other values to z and try again.

13. Place the Complex to Re/Im block on the block diagram and attach indicators.  Click run and verify that they are working.  

14. Go to the block diagram view and add another complex variable input by holding the Ctrl key down and clicking and dragging the z block.  Label this new block w.

15. Get an add block
 and add z to w.  Attach an indicator.  Verify that it works. Note the default label for the add result is ‘x+y’.  You may wish to change it to ‘z+w’.
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16. You can combine the arrays z and w into one array.  

a. Do this by going to Programming»Array and selecting Build Array.
[image: image26.png]~ Progranming
L array.

User Lbraries
Select a v,
» D3P First







b. Click on the bottom of the Build Array icon and stretch it until it has two inputs.


c. Right-click on Build Array and select Concatenate Inputs.

d. Attach z and w to the inputs.


e. Create an indicator for the output.  Hint:  Right-click, create.


f. Run the VI.  Does it work as expected?


g. This also works for combining scalars into an array.

17. Save this as Complex Arrays.

You seen that it is rather easy to build up entire arrays of complex numbers and manipulate them.  Next you’ll see how to build some signals.

2.2 Generating Signals

In this section we’ll see that it’s easy to generate waveforms in LabVIEW.  A waveform is a datatype that contains an array of sample values and information about the sampling rate.

1. Start with a new VI by clicking File:New VI.

2. Select the block diagram <Ctrl-E>.

3. Right-click and then click the pushpin in the upper left.  Click on DSP First. You will see:
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These are the VIs for this class.  


4. Select the DSP First Function Generator (upper left) and place it on the block diagram.


5. Go to the Front Panel <Ctrl-E>, right-click, choose DSPFirst, then select and place the TripleDisplay.  
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This will place a VI on the block diagram.  If the TripleDisplay block has the connector on the right side rather than the left side, right-click on it and select Change to Indicator.

6. Attach the two as shown.
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7. Click the run button.

8. Use the context help
 to learn what the Amplitude, Frequency, Phase, and Sampling Info inputs on the DSP First Function Generator default to.  What are the units on the Phase?

9. Attach controls to Amplitude, Frequency, and Phase inputs.  Hint: right-click on the input and select Create.

10. Try different values.

The DSP First Function Generator generates cosines by default.  You can generate other waveforms with it by attaching a control to the signal type connector.  There are many other sinusoidal generators in LabVIEW, however they generate sines.  Since Electrical Engineers use cosines, stick with our generator.

2.3 LabVIEW Sound

The exercises in the section involve sound signals, so you should bring headphones to the lab for listening.


1. Generate a tone (i.e. a sinusoid) in LabVIEW and listen to it.  The previous section showed how to generate a sinusoid.  For this part, the frequency of your sinusoid tone should be 2000 Hz and its duration should be 1 second.  Use a sampling rate equal to 11025 samples/sec.  To set the sampling rate and duration, right-click on the sampling info terminal on the DSP First Function Generator (bottom left) and select Create»Constant.  The top number in the box is the sampling rate and the bottom is the number of samples.  Change these to match above.

2. Listen to the tone by clicking the Play Sound check box on the TripleDisplay.  Click run.  Does the tone sound correct?  

3. The Time Domain display is not very informative at this scale.  See if you can zoom in to see something more sinusoidal.  Click the magnifying glass at the bottom of the graph for zoom options.

4. Try different amplitudes and frequencies.  To make this easier, change the input constants to controls.  Hint:  right-click the constant and select Create»Control.  Delete the constant and attach the control.  Can the frequency be too high or too low?

Instructor Verification (separate page)


3 Lab Exercise:  Manipulating Sinusoids with LabVIEW

Now you're on your own. Include a short summary of this Section with plots in your Lab report.  Build a LabVIEW VI to do steps (a) through (d) below. Include a printout of both the front panel and the block diagram with your report.


(a) Set the sampling info so that the Function Generator will produce approximately two cycles of the 4000 Hz sinusoids defined in the next part, part (b). Set the sampling rate so that you have at least 25 samples per period of the sinusoidal wave.


(b) Generate two 4000 Hz sinusoids with arbitrary amplitude and time-shift.
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Select the value of the amplitudes and time-shifts as follows:  Set A1 equal to your age and set A2 = 1.2A1.  For the time-shifts, set 
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 where D and M are the day and month of your birthday and T is the period.  Make a plot of both signals over the range of 
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.  For your final printed output in part (d) below, place three TripleDisplays one above the other on the front panel.


(c) Create a third sinusoid as the sum:
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.  In LabVIEW this amounts to summing the vectors that hold the values of each sinusoid.  Make a plot of x3 over the same range of time as used in the plots of part (b).

(d) Before printing the three plots, put a title on each subplot, and include your name in one of the titles.  Then right-click on each plot and select Data Operations»Export Simplified Image…
.  Put the plot on your clipboard and then paste into your word processor.

3.1 Theoretical Calculations

Remember that the phase of a sinusoid can be calculated after measuring the time location of a positive peak,
 if we know the frequency.


(a) Make measurements of the “time-location of a positive peak” and the amplitude from the plots of x1 and x2, and write those values for Ai and 
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 directly on the plots.  Then calculate (by hand) the phases of the two signals, x1(t) and x2(t),  by converting each time-shift 
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 to phase. Write the   calculated phases (i directly on the plots.
Note: when doing computations, express phase angles in radians, not degrees!

(b) Measure the amplitude A3 and time-shift 
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directly from the plot and then calculate the phase (3 by hand.  Write these values directly on the plot to show how the amplitude and time-shift were measured, and how the phase was calculated.

(c) Now use the phasor addition theorem. Carry out a phasor addition of complex amplitudes for x1(t) and x2(t) to determine the complex amplitude for x3(t).  Use the complex amplitude for x3(t) to verify that your previous calculations of A3 and (3 were correct.

4 LabVIEW things to remember for future labs:

· Where to find DSP First demos


· How to turn on and use Context Help


· Using right-click to find palettes


· How to search for VIs (blocks)


· Using right-click to attach constants, controls, and indicators


· Where to find the complex operators


· How to create array controls


· How to declare the ‘type’ of an array


· How to change the data representation of a numeric input


· How to generate a cosine waveform


· How to change the sampling rate and number of samples generated


· How to use a TripleDisplay.


· How to copy a plot to be pasted into a word processor.


· …  What else?
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I find that clicking in between the textboxes is a good place to “grab” the entire control for repositioning.











� Read Section I (pages 1-19) of the Introduction to LabVIEW – Six Hour Course (on Angel) for more details.   



� You’ll have to type 3+4i.



� Reminder:  right-click on the block diagram to get a palette of blocks.  Click on Numeric and select the Add block.  If you aren’t sure where a block is, right-click on the background and then click on Search.  Type the name of the block for which you are looking.



� If the small context help window isn’t appearing, type <Ctrl-H> to make it appear.



� If Export Simplified Image doesn’t appear, press Alt-PrintScrn and paste into your word processor.



� Usually we say time-delay or time-shift instead of the “time location of a positive peak.”
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