
DSP First, 2e Signal Processing First

Lab 15b: FIR Filter Design and PeZ: The z, n, and O! Domains

The lab report/verification will be done by filling in the last page of this handout which addresses a list
of observations to be made when using the PeZ GUI.

Verification: The Warm-up section of each lab must be completed during your assigned Lab time
and the steps marked Instructor Verification must also be signed off during the lab time. When you have
completed a step that requires verification, simply raise your hand and demonstrate the step to the TA or
instructor. Turn in the verification sheet to your TA before leaving the lab.

The lab report for this week will be an Informal Lab Report. The report will be due during the period
5 – 11 Apr. at the start of your lab.

1 PeZ: Introduction

In order to build an intuitive understanding of the relationship between the location of poles and zeros in the
z-domain, the impulse response hŒn� in the n-domain, and the frequency responseH.ej O!/ (the O!-domain),
A graphical user interface (GUI) called PeZ was written in Matlab for doing interactive explorations of the
three domains.1 PeZ is based on the system function, represented as a ratio of polynomials in z�1, which
can be expressed in either factored or expanded form as:
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whereM is the number of zeros andN the number of poles. If the poles and zeros occur in pairs that satisfy
the complex-conjugate property, then the following property holds:

A polynomial with real coefficients has roots that are real, or occur in complex-conjugate pairs.

The PeZ GUI is contained in the SP-First toolbox. To run PeZ, type pezdemo at the command prompt
and you will see the GUI shown in Fig. 1.2

1.1 Controls for PeZ using pezdemo

The PeZ GUI is controlled by the Pole-Zero Plot panel in the upper left where the user can add (or delete)
poles and zeros, as well as move them around with the pointing device. For example, Fig. 1 shows a case
where two (complex-conjugate) zeros have been added, and PeZ has automatically included two poles at
z D 0 so that the system is causal. The button named ZZ was used to add these zeros; the button PP would
be used to add poles. By default, the Add with Conjugate property is turned on, so poles and zeros are
typically added in pairs to satisfy the complex-conjugate property, giving real coefficients.

To learn about the other controls in pezdemo, access the menu item called “Help” for extensive infor-
mation about all the PeZ controls and menus. Here are a few things to try. In the Pole-Zero Plot panel

1The original PeZ was written by Craig Ulmer; a later version by Koon Kong is the one that we will use in this lab.
2The command pez will invoke the older version of PeZ which is distinguished by a black background in all the plot regions.
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Figure 1: GUI interface for pezdemo (ver 2.9) running in Matlab 2016a. A length-3 FIR filter is shown.
Zero locations are given in rectangular coordinates.

you can selectively place poles and zeros in the z-plane, and then observe (in the other plotting panels) how
their placement affects the impulse and frequency responses. The red ray in the z-domain window is tied
to the red vertical lines on the frequency responses, and they move together. This helps identify frequency
domain features that are caused by pole locations or zero locations, because the angle around the unit circle
corresponds to frequency O!. In PeZ an individual pole/zero pair can be moved around and the corresponding
H.ej O!/ and hŒn� plots will be updated as you drag the pole (or zero). Since exact placement of poles and
zeros with the mouse is difficult, an Edit button is provided for numerical entry of the real and imaginary
parts. Before you can edit a pole or zero, however, you must first select it in the list of Pole Locations or
Zero Locations . Next, you will have to make the necessary change in the edit field (box above the Edit
button) and then press the Edit button for the change to take effect. Removal of individual poles or zeros
can also be performed by using the -P or -Z buttons, or with the Delete button. Note that all poles and/or
zeros can be easily cleared by clicking on the -A button.

1.2 GUI for Filter Design

The SP-FirstGUI called filterdesign illustrates several filter design methods for LPF, BPF and HPF filter.
The interface is shown in Fig. 2. Both FIR and IIR filters can be designed, but we will only be interested
in the FIR case which would be selected from the drop-down list in the upper right. Once FIR Filters
is selected, the window type should be selected from the drop-down list in the lower right. Lastly, it is
necessary to set the order of the FIR filter and the cutoff frequency; these parameters can be entered in the
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edit boxes.

Figure 2: Interface for the filterdesignGUI. The default setting for the frequency axis is analog frequency
f in Hz, but can be changed to O! via the Edit->Show Radian Frequency menu selection. When the
Filter Choice is set to FIR Filters, many different window types can be selected, including the Hamming
window and the Rectangular window (i.e., no window).

2 Pre-Lab

Try various operations with PeZ to gain some familiarity with the interface. Here are two suggested filters
that you can create.

2.1 Create an FIR Filter with PeZ

Implement the following FIR system: H.z/ D 1 � z�1
C z�2 by factoring the polynomial and placing the

two zeros correctly. Observe the following two facts:

� The impulse response hŒn� values are equal to the polynomial coefficients ofH.z/.

� The frequency response has nulls because the zeros of H.z/ lie exactly on the unit circle. Compare
the frequencies of the nulls to the angles of the zeros

Move the zero-pair around the unit circle and observe that the location of the null also moves.

2.2 Create an IIR Filter with PeZ

Implement the following first-order IIR system: H.z/ D
1 � z�1

1C 0:9z�1

by placing its pole and zero at the correct locations in the z-plane. First, try placing the pole and zero with the
mouse, and then use the Edit feature under Pole Location or Zero Location to specify exact locations.
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Since PeZ wants to add complex-conjugate pairs, you might have to delete one of the poles/zeros that were
added; or you can turn off the Add with Conjugate feature. Look at the frequency response and determine
what kind of filter you have, i.e., HPF, LPF, or BPF.

Now, use the mouse to “grab” the pole and move it from z D �0:9 to z D 0 and then to z D C0:9. To
move along the real axis, you can use Options -> Move on Real Line from the GUI menu. Observe
how the frequency response changes. Describe the type of filter for z D 0:9, i.e., HPF, LPF, or BPF.

2.3 Design Filters with the filterdesign GUI

The SP-FirstGUI called filterdesign illustrates several filter design methods for LPF, BPF and HPF filter.
The interface is shown in Fig. 2. Both FIR and IIR filters can be designed, but we will only be interested in
the FIR case which would be selected from the drop-down list in the upper right.

For practice, design two lowpass FIR filters with M D 30 and O!c D 0:4� D 2�.1600=8000/. Create
one using a Hamming window, the other with a Rectangular window. Right click on the plot to see options
for displaying the impulse response and the pole-zero plot. How many zeros are in the pole-zero plot, and
why are so many of them located on the unit circle?

3 Warm-up

The lab verification requires that you write down your observations on the verification sheet when using
the PeZ GUI. These written observations will be graded.

3.1 Relationships between z, n, and O! domains

Work through the following exercises and keep track of your observations by filling in the worksheet at the
end of this assignment. In general, you want to make note of the following quantities:

� Is the length of hŒn� finite or infinite? For the FIR case, what is the total length of the filter?

� How does hŒn� change with respect to its rate of decay for IIR filters? For example, when the impulse
response is of the form hŒn� D anuŒn�, the impulse response will fall off more rapidly when a is
smaller; and if jaj > 1 the impulse response will grow without bound.

� A stable system is one that obeys the bounded-input gives a bounded-output property. When the
impulse response grows without bound, the output is not bounded even though the input is ıŒn� with
is bounded by one.

� If hŒn� exhibits an oscillating component, what is the period of oscillation? Also, estimate the decay
rate of the “envelope” that overlays the oscillation.

� How doesH.ej O!/ change with respect to null location, peak location and/or peak width?

Note: review the “Three-Domains - FIR” under the Demos link for Chapter 7 and “Three-Domains - IIR”
under the Demos link for Chapter 8 for movies and examples of these relationships.

3.1.1 Real Poles

(a) Use PeZ to place a single pole at z D �1
2
and a single zero at z D 1. You may have to use the

Edit button to get the location exactly right. Describe the important features of the impulse response
hŒn�, and also the important features of the frequency response H.ej O!/. Define the passband as the
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region where the magnitude response is greater than 90% of the maximum; and the stopband as the
region where the magnitude response is less than 10% of the maximum. Use freqz if you need more
precision in measuring the passband and stopband. Finally, use these plots in PeZ as the reference for
answering the next three parts.

(b) Move the pole slowly from a location close to the origin out to z D �1
2
, and then to out to z D �0:999.

Stay on the real axis by using Options->Move on Real Line from the GUI menu. Observe the
changes in the impulse response hŒn� and the frequency response H.ej O!/. Record your observations
on the Verification Sheet.
When you move poles and zeros, the impulse response and frequency response plots are updated
continually in PeZ. Select the pole you want to move and start to drag it slowly. At the same time,
watch for the update of the plots in the impulse response and frequency response panels.

(c) Move the pole from z D �0:999 to a radius outside the unit circle. Describe the changes in hŒn�.
Explain how the appearance of hŒn� validates the statement that the system is not stable. In this case,
the frequency responseH.ej O!/ is not legitimate because the system is no longer stable.

(d) In general, where should poles be placed to guarantee system stability? By stability we mean that the
system’s output does not blow up as n!1.

Instructor Verification (separate page)

3.1.2 Zeros

The 6-point running-sum FIR digital filter has the following system function:

H.z/ D

5X
nD0

z�n
D
1 � z�6

1 � z�1

(a) Use the roots function in Matlab to determine the zeros ofH.z/ for this 5-th order FIR filter.
Note: The formula for H.z/ involves a numerator-denominator cancellation that removes the zero at
z D 1. This is called a pole-zero cancellation.

(b) In PeZ place the five zeros of the FIR filter at the correct locations; use the edit feature to enter the
exact value of the zeros. Observe that the impulse response will be all ones when you have the correct
zero locations. Describe the frequency response of the filter: low pass versus high pass.

(c) List all the frequencies, O! 2 .��; ��, that are nulled by the length-6 FIR filter.

(d) Make a different FIR filter that has the system function Hc.z/ D 1 � z�6 which is the numerator in
part (a). Use PeZ to place the six zeros of this filter, or add one zero to the previous configuration.
Write a formula for the impulse response, hcŒn� using weighted, shifted impulses.

(e) The frequency response of the FIR filter in the previous part is called a comb filter. Explain why is it
called a “comb”, and determine where its nulls are located for O! 2 .��; ��.

Instructor Verification (separate page)

McClellan, Schafer, and Yoder, DSP First, 2e, ISBN 0-13-065562-7.
Prentice Hall, Upper Saddle River, NJ 07458. ©2015 Pearson Education, Inc.

5 McClellan, Schafer and Yoder, Signal Processing First.
Prentice Hall, Upper Saddle River, New Jersey, 2003. ©2003 Prentice Hall.



3.2 GUI for Filter Design

The SP-First GUI called filterdesign performs basic filter design methods for FIR and IIR filters that
are lowpass (LPF), bandpass (BPF), or highpass (HPF). The interface is shown in Fig. 2. We will be
primarily interested in the FIR case which would be selected from the drop-down list in the upper right.
Other parameters that must be chosen to perform a design are: the window type, the filter order and the
cutoff frequency; these parameters can be entered in the edit boxes. The cutoff frequency can be entered as a
normalized frequency . O!/ after clicking on the “Frequency” label of the plot which will toggle the frequency
axis between analog frequency (Hz) and O!.

3.2.1 Design Some Filters

Design two lowpass FIR filters withM D 50 and O!c D 0:6� , one using a Hamming window, the other with
a Rectangular window. Repeat the process with two FIR bandpass filters .M D 50/ using cutoff frequencies
at O!c1

D 0:3� and O!c2
D 0:6� .

Discussion questions to consider: How close is the designed filter to an ideal filter? Is the Hamming-
window design better? Why? How many zeros are found in the z-plane? Where are they located? How do
the zero locations relate to the passbands and stopbands of the filters?

Instructor Verification (separate page)

4 Lab Exercise

The objective of the lab exercise is to develop capability in designing FIR filters that can be lowpass, highpass
or bandpass filters.

4.1 GUI for Filter Design

The SP-First GUI called filterdesign was used to design FIR filters, see the interface in Fig. 2. The filter
coefficients can be “exported” from the filterdesign GUI under the menu File->Export Coeffs. To
have some filters for comparison, redo the designs from the warm-up (Section 3.2.1), and export the filter
coefficients to the workspace under unique names. Then you can get the frequency response in Matlab
using the freekz function (or freqz) followed by a plot command.

4.1.1 Passband Defined for the Frequency Response

Frequency-selective digital filters, e.g., LPFs, BPFs and HPFs, have a frequency response magnitude that
is close to one in some frequency regions, and close to zero in others. For example, the plot in Fig. 3 is a
lowpass filter whose magnitude is close to one when the frequency O! is near zero. This region where the
magnitude is close to one is called the passband of the filter. It will be useful to have a precise definition of
the passband edges, so that the passband width can be measured and we can compare different filters.

(a) From the plot of the magnitude response, e.g, in the filterdesign GUI, it is possible to determine
the set of frequencies where the magnitude is very close to one, as defined by

ˇ̌̌
jH.ej O!/j � 1

ˇ̌̌
being

less than ıp. This deviation from one is called the passband ripple. A common choice for the passband
ripple is between 0.01 and 0.1, i.e., 1% to 10%. The set of frequencies in a passband should be a
region of the form O!1 � O! � O!2.

(b) For a lowpass filter, the passband region extends from O! D 0 to O!p, where the parameter O!p is called
the passband edge. For the two LPFs designed in Section 3.2.1 determine an accurate estimate of
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O!p assuming a passband ripple (ıp) of 0.1 for the Rectangular window case, and ıp D 0:01 for the
Hamming window case.3 Compare these actual passband edges to the design parameter O!c which is
called the cutoff frequency.
Note: There is often confusion between O!c and O!p, as these examples illustrate.
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Figure 3: Passband and stopband defined for a typical lowpass filter. This particular filter is a length-21
FIR filter designed with a rectangular window and a sinc function with a cutoff frequency of O!c D 0:32� .
The passband and stopband ripples are defined to be 0.1, from which the passband and stopband edges can
be measured. The approximate value of the passband edge is O!p D 0:27� � 0:85; the stopband edge,
O!s D 0:366� � 1:15.

4.1.2 Stopband Defined for the Frequency Response

When the frequency response (magnitude) of the digital filter is close to zero, we have the stopband region of
the filter. In the lowpass filter example of Fig. 3, the magnitude is close to zero when the frequency O! is near
� (a high frequency). When the frequency response of a LPF is plotted only for nonnegative frequencies,
the stopband will be a region of the form O!s � O! � � . The parameter O!s is called the stopband edge. We
can make a precise measurement of the stopband edge as follows:

(a) For the lowpass filters from Section 3.2.1, make plots of the magnitude of the frequency response
using freekz (or freqz) and plot. Use the filter coefficients exported from the GUI.

(b) From the plots of the magnitude response that you made in the previous part, determine the set of
frequencies where the magnitude is nearly zero, as defined by jH.ej O!/j being less than ıs D 0:1 for
the Rectangular window case, and less than ıs D 0:01 for the Hamming window design.

(c) Compare the values of O!s found in the previous part to the design parameter O!c .

4.1.3 Transition Zone of the LPF

The difference between the stopband edge and the passband edge is called the transition width of the filter:
� O! D O!s � O!p. The smaller the transition width, the better the filter because it is closer to the ideal filter
which has a transition width of zero.

3The filterdesign GUI has a zoom capability (Options->zoom), and the grid can be turned on (Options->grid). Also,
when the pointer is placed to hover over the frequency response the coordinates are read from the plot.
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(a) For the two lowpass filters from Section 3.2.1, determine the transition width.
Note: Comment on the statement, “it is usually true that filters with smaller transition widths have
larger ripples.”

(b) Design two new LPFs that have the same cutoff frequency, O!c D 0:6� , but twice the order, i.e.,
M D 100. Repeat the measurement of O!p, O!s and � O! for these two LPFs.

(c) Comparing to the values of � O! from part (a); when the order doubles, describe what happens to the
transition width.

4.2 Function for Lowpass Filter Design

The Matlab filterdesign GUI designs lowpass filters using the following “Hamming-sinc” formula for
the impulse response. Recall that for FIR filters the impulse response values are the filter coefficients:

hŒn� D
�
0:54 � 0:46 cos.2�n=M/

� �sin. O!c.n �M=2//

�.n �M=2/

�
for n D 0; 1; 2; : : : ;M (2)

The parameter M is the filter order. The first term of hŒn� in (2) is called a Hamming window4 and the
second term is called a “sinc function.” The design parameter O!c is called the cutoff frequency of the filter
because it determines (roughly) where the passband and stopband regions of the frequency response will
be located. The GUI can also design bandpass and highpass filters, but then variations of the formula are
needed for the BPF and HPF cases. In the following parts, you will write an M-file that implements (2) and
use the GUI to check that it is correct.

(a) Write a Matlab function for the Hamming window, and make a stem plot of the window versus n, for
M D 30 which is a length-31 window.

(b) Write aMatlab function that will produce the impulse response of a lowpass filter using theHamming-
sinc formula. The only trick in implementing (2) is handling cases where you might divide by zero.

(c) Use your M-file to design a 50-th order FIR filter with its cutoff frequency at O!c D 0:6� . Make a stem
plot of the impulse response.

(d) The filterdesign GUI was already used to create the same filter as in part (b). Export the filter
coefficients and make a stem plot to verify that you get exactly the same result.

(e) In the GUI, display a pole-zero plot for this filter and take a screen shot. Count the number of zeros.
Determine how many zeros lie exactly on the unit circle, and explain whether they contribute to the
stopband or passband.

4.3 Bandpass Filter Designed from Lowpass Filters

Here’s an idea: subtract two LPFs to get a BPF. If you think in terms of the magnitude response only, then
it’s relatively easy to see that this could be true.

(a) Use your Hamming-sinc M-file to design two 50-th order FIR filters, h1Œn� and h2Œn�, one with a cutoff
frequency at O!c D 0:6� , the other at O!c D 0:3� . Subtract the impulse responses (h1Œn�� h2Œn�) and
make a stem plot of the resulting impulse response (call it h3Œn�).

4Other windows can be used, in which case the sinc function is retained but a different formula is used for the first term.
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(b) Use freqz (or freekz) to calculate the frequency response from h3Œn�. Then plot the magnitude
versus O! over the range 0 � O! � � . Annotate the plot to show where the cutoff frequencies (0:3�
and 0:6�) lie.

(c) Use the filterdesign GUI to create a BPF with the same two cutoff frequencies (0:3� and 0:6�).
Export the filter coefficients and make a stem plot to verify that you get exactly the same result.
Compare the frequency response in the filterdesign GUI to what you plotted in part (b).

(d) Finally, determine the upper and lower stopband edges and passband edges of the BPF, as well as
the upper and lower transition widths. There are two transition zones in a BPF. Compare these
measurements to those obtained earlier for the LPF case.
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Lab: FIR Filter Design and PeZ: The z, n, and O! Domains
WORKSHEET

Turn this page in at the end of your lab period. For each verification, be prepared to explain your answer and
respond to other related questions that the lab TA’s or professors might ask.

Name: Date of Lab:

Part Observations

3.1.1(a)
hŒn� decays exponentially with or without oscillations; which?

H.ej O!/ has a passband for � O! � , and a stopband for � O! �

3.1.1(b) Move pole out to unit circle: describe changes in impulse response and frequency response.

3.1.1(c) Move pole outside unit circle: describe changes in impulse response.

3.1.1(d) Stability Condition

Verified: Date/Time:

Part Observations
3.1.2(a) List roots:

3.1.2(b) Describe frequency response: LPF, BPF, or HPF?

3.1.2(c) List nulling frequencies:

3.1.2(d) hcŒn� D

3.1.2(e) Why is it called a comb filter? where are the nulls?

Verified: Date/Time:

Part 3.2.1: Design FIR filters using the filterdesign GUI.

Verified: Date/Time:
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